< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

VT-d for IOMMU not available in BIOS?

MichaelAnders

New Member
I installed Proxmox for virtualization purposes on this device. Worked perfectly!

However: I cannot do PCIe passthrough of the 2nd LAN port which is required for pfSense which should run in a VM as IOMMU is not available...

There is no option to enable "VT-d" in the BIOS - why did you not add this? Also, VT-x is missing in the BIOS. Both are mentioned as available in the CPU by Intel: Intel N5030 CPU spec

If these were available this device would be THE solution for many people who do not want to pay > $600 for an Asrock/* NUC just to use for proxmox / pfsense.

I have another 28 days left before I need to return the device.

If by that time a BIOS update is available which adds these that would be great and I'll promote your hardware, assuming it'll work the way I expect (but I don't see extra problems there).
 

joey

Administrator
Staff member
The VT-x and VT-d functions of the GK50 are already enabled by default and hidden in the bios. Hope this information is helpful to you, thank you.
 

MichaelAnders

New Member
Thank you for the fast reply, joey!

If that is the case then something is broken somewhere - at least for Linux. I don't use Windows so I have not tested it there.

Reproduce:
1) Install proxmox 7.1 on the system
2)- Set up a VM using e.g. a debian ISO (no need to install, just to set up the VM for the next step)
3) Under "Hardware" of the VM, "Add PCI device"

Error message:
"No IOMMU detected, please activate it.See Documentation for further information."

dmesg | grep DMAR also shows no sign of VT-d / IOMMU becoming enabled

As this is a pretty new kernel (5.13.19), I'd bet on an issue in the BIOS and not in the kernel...
 

Carbon fib'er

Active Member
something is broken somewhere - at least for Linux. I don't use Windows so I have not tested it there.
If you could install Windows and test it there, that would be conclusive. And.or, Sparky Linux's "rolling" distro (currently 2022.03) comes with 5.16 (and 5.17-rc7 available to install from its repro). That should be a quick way to rule out something about Linux (compared to the 5.13 you're using).
 

Carbon fib'er

Active Member
You may aready know about this. But, I was googling and read that sometimes people have to enable iommu via grub cmdline parameters? For example: intel_iommu=on or amd_iommu=on. "If those work, you can try replacing them with iommu=pt or amd_iommu=pt. The pt option only enables IOMMU for devices used in passthrough and will provide better host performance. However, the option may not be supported on all hardware. Revert to previous option if the pt option doesn't work for your host." I read quite a few things from the past couple years saying many distros disable it by default.

I read that for intel, the command acpidump | grep -E "^DMAR" can inform you if it's enabled.
 
Top Bottom