< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

USB3 Not Handling Disks or Thumb Drives

MAT_Blue

New Member
I have an X35G.
I've tried using the USB 3.0 ports (both the type A and type C plugs) with USB Flash drives, with external USB3 enclosures and with a USB3 Camera. Some combinations work and some don't. Here's what I've found:
USB3 Type A ports - work for USB Thumb drives and the camera but not for external USB3 disk enclosures (with drives of 3 or 4 TB)
- the disk enclosures work on the USB2 ports, but at much slower speeds, obviously
USB3 Type C port ("Thunderbolt") - does not work for USB thumb drives or the camera. Works for one USB3 disk enclosure but not for another one.

I have another computer (desktop) with USB3 Type A and Type C ports and all of this works correctly on it in any combination.
So, what's going on with the USB3 ports on the MiniPC?
On the support website for the X35G, there is a download for "intel_thunderbolt Driver_3.19.150.rar" but this is an ANCIENT version from the year 2014. I tried to install it on the X35G and it failed.
 

swbrains

Member
Are there any BIOS settings on the mini PC that control how the USB ports work? Perhaps they are configured differently in the BIOS on the mini than they are on the desktop...
 

joey

Administrator
Staff member
this is caused by the power required by the device you connect to exceeds the output power of the minipc itself. I suggest you use an independently powered hard disk or other device. Hope this information can help you.
 

MAT_Blue

New Member
Power is not the problem. All of the devices have their own power supply. Why would each device work on some ports but not on others? In fact, they ALL work on the USB2 port which would have the least available power.
The problem is on the X35G, not with the devices. Period.
 
Top Bottom