< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

usb ports and wifi drivers

giukas

New Member
While i use 20.04 also on my work laptop, dude, move on! :) I understand the desire to run LTS but i didn't even tried on this machine so close before the next release and it is a good test to see what will change. Well, my opinion.

Short: 21.10 works fine for me, consider to upgrade.

wlan:
wlan works for me with xbuntu 21.10. Warning: the latest Kernel update 5.13.0-23 is not working at all - slow boot, no eth, no X ... completely broken as it seem. -22 works fine.

root@hm90:~# lsmod | grep mt
mt7921e 77824 0
mt76_connac_lib 36864 1 mt7921e
mt76 77824 2 mt7921e,mt76_connac_lib
mac80211 1024000 3 mt76,mt7921e,mt76_connac_lib
cfg80211 892928 4 mt76,mt7921e,mac80211,mt76_connac_lib

root@hm90:~# iwconfig
wlan0 IEEE 802.11 ESSID:"xxx"
Mode:Managed Frequency:5.18 GHz Access Point: xxx
Bit Rate=1.2009 Gb/s Tx-Power=3 dBm
Retry short limit:7 RTS thr:eek:ff Fragment thr:eek:ff
Encryption key:eek:ff
Power Management:eek:n
Link Quality=69/70 Signal level=-41 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:1 Missed beacon:0
(I'm using oldstyle device names ...)

here is what you have to do to load the module automatically:
echo 'alias pci:v000014C3d00000608sv*sd*bc*sc*i* mt7921e' > /etc/modprobe.d/rz608.conf
echo 'SUBSYSTEM=="drivers", DEVPATH=="/bus/pci/drivers/mt7921e", ATTR{new_id}="14c3 0608"' > /etc/udev/rules.d/99-rz608.rules
modprobe mt7921e
echo "14c3 0608" > /sys/bus/pci/drivers/mt7921e/new_id

I was a little unpredictable in the beginning, maybe power down the system instead of reboot, iirc that helped. Now it works all the time. I don't have dualboot, but other systems with it and sometimes a simple reboot doesn't work to get hardware recognized.

bluetooth:
not done much with it, but i have a script running every 5 minutes that checks my bt thermometers and that works fine.

usb: no problems so far for me, i have a wireless keyboard connected all the time (with usb dongle). But i rarely use it, it is a head less "server". Maybe change front/back ports.

I'm still setting it up, today i had some problems after the kernel update, even after going back to previous version but it seems to work ok now. Anyway, still work to do :)
I outlined above what works even with many kernels. It just needs to cold boot but wifi works. for usb I did what @joey suggested and it's fine. thanks for replying anyway
 
Top Bottom