< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

Power outage during N3450 Apollo update

MechanicJB013

New Member
Hello all,
First thread so bear with me. I have a MinisForum N34 and during a recent update the power went out. When the power came back on I tried to boot up and the blue LED on the case lit up but nothing else, no splash screen, couldn't get into bios, just a black screen. I am fairly new to all of this, what happened and can someone help? Did the BIOS get corrupted? Is there a way to reinstall the BIOS? Any help is supremely appreciated!!!
 

joey

Administrator
Staff member
You can use the following methods to restore Z83.
1)Long press the reset hole for 30 seconds to restore Z83F, refer to the figure below
678
2)Please refer to the figure below, unplug the battery, and short-circuit the two pins of the battery socket for more than 30 seconds (without power supply)
679
 

MechanicJB013

New Member
So as I have already posted in Kenhall999's thread titled "GN34 Mini PC Apollo Lake Won't Turn on after house power failure" I have already tried to finish not only what you directed in that post and this post, but I read through all the forums trying to find the answer, but no luck so far. What about the BIOS file?
 
Top Bottom