< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

GK50 - one ethernet port instead of two?

ernstoud

New Member
Everywhere I look, on Amazon and even on the Minisforum store internationally or the Minisforum German store, the GK50 is advertised as having two ethernet ports. Even in reviews on YouTube it is shown to have two Ethernet ports.

I need two Ethernet ports so I bought a GK50.

When it arrived it only has one Ethernet port. Huh?

I earlier bought a Minisforum X35G and I am very happy with it. But this GK50 now is a disappointment.

What gives?
 

Carbon fib'er

Well-Known Member
Did you buy it from Minusforum, or a reseller? That adds a lot to the confusion. On the US Amazon site there are 2-3 sellers who are not Minusforum. They buy in bulk and sell. Minusforum doesn't provide support for those. A lot of people don't realize that until after they buy.

If you paid with a credit card, and Minusforum won't make this right, you may have recourse through the credit card company. (In the US they will reverse the charge over clearly false advertising, dead-on-arrival products.). But, it's important to document as much as you can (use archive.org to archive web pages in addition to taking screen shots.). The first thing to do is contact the seller and start the process. But, document everything (if your credit card company protects you).
 

ernstoud

New Member
Thanks for the reply. It was bought from a reseller on Amazon. I contacted that reseller (in Poland). We agreed on a partial refund for which I can buy a USB to Ethernet adapter.

My question here was more focused on the question how this can happen. Reviews on YouTube , for instance:

This clearly show a GK50 with two ports but the product has changed without changing its product number. Earlier on minisforum.com it also showed an image with two ports. Now it shows one port but it also pictures of the bottom lid of the GK41 and of the GK41 fan (the GK50 is passive cooled).

Here https://store.minisforum.de/products/elitemini-gk50 it is still shown with 2 ports. That site is or claims to be the European Minisforum site.

It appears Minisforum does not have their configuration management and marketing aligned.
 

Carbon fib'er

Well-Known Member
My question here was more focused on the question how this can happen. Reviews on YouTube , for instance:
I believe I've seen Joey say there are two models. This causes confusion with the bios. (Someone flashed their onsy with the twosy, or vice versa.). This is made more confusing by the way Minisforum doesn't publish their bios on the support page so people can at least see what's what, the latest version, revisions of hardware.

I think changing a model the way they did is a bad idea. Causes confusion. But, I've seen big-name computer makers do that. I had a Thinkpad (I think it was, maybe an HP) that had a less powerful cpu than I thought it would have (when I bought it off craigslist used). When I discovered the difference and searched for more info, I realized there had been a revision. The original was lightweight, and was changed after a couple years.

Minisfoum could improve this situation by more prominently identifying model numbers as "Rev. 1, Rev 2." Most hardware makers do that instead of relying on someone to know what the difference is (visibly).
 
Top Bottom