< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

For some devices, after installing Ubuntu system, the solution that cannot be turned on without HDMI is not available.

Huang

Administrator
please update you BIOS (only support linux Ubuntu),as the below link :http://www.mediafire.com/file/c0evv0dhu9d9c4z/X5R110-Ubuntu.rar/file


1. Unzip the file and copy all the files to the root directory of the U disk. Note that the U disk partition must be in FAT32 format.

2. Connect the USB flash drive and press F7 to boot into UEFI SHELL.

3. Run the batch BIOS.nsh to start updating the BIOS.

4. Do not interrupt during the BIOS update process.

5. After the BIOS is updated, please power off, clear CMOS, and then connect to power to boot.

6. Press the Del key to enter the BIOS Setup interface, load default, then save and exit.
 

wvreeven

New Member
Thanks very much! I confirm that the BIOS update works and that the device now once again boots without the need of having an HDMI device attached.
 

devx

New Member
Hello,
I am attempting to run a dual boot system (Windows 10 and Ubuntu 18.04). I updated the BIOS based on the files and instructions from this thread to help solve windows issues.
Now I am having issues with Ubuntu. There is a bios update provided above (for booting without HDMI), as well as a bios update provided in another thread (to get Wifi working). I need both fixes. Can you help me determine which is the correct BIOS update to use? Is there a BIOS update that solves all three problems (windows, ubuntu wireless, ubuntu boot w/o hdmi)?

Thank you!
 
Last edited:

Huang

Administrator
Hello,
I am attempting to run a dual boot system (Windows 10 and Ubuntu 18.04). I updated the BIOS based on the files and instructions from this thread to help solve windows issues.
Now I am having issues with Ubuntu. There is a bios update provided above (for booting without HDMI), as well as a bios update provided in another thread (to get Wifi working). I need both fixes. Can you help me determine which is the correct BIOS update to use? Is there a BIOS update that solves all three problems (windows, ubuntu wireless, ubuntu boot w/o hdmi)?

Thank you!
I don't recommend using this device for dual system booting, because this device has a small storage capacity, and if you use dual systems, it may cause your computer to change cards.
Secondly, if you are not using HDMI to boot, you cannot support dual system boot.
If you will be connected to HDMI for booting, you can use this BIOS: http://bbs.minisforum.com/threads/the-z83-f-is-now-updated-with-bios.837/
You can refer to this BIOS setting: http://www.mediafire.com/file/bnudago1uqspbqu/weibu_Z83-F__BIOS_%E8%AE%BE%E5%AE%9A.docx/file
 

skidog

New Member
Updated my Z83-F bios per instructions above. BIOS update said was successful. On 1st boot after flashing I'm getting nothing on the screen....VGA or HDMI. Totally blank. Suggestions??
 
Top Bottom