< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

Fan control in Linux

skip10

New Member
Hi, I have recently purchased a MINISFORUM GN34 and have installed Ubuntu 18.04 Server on it which is working well. However, the cooling fan does not appear to correctly turn on/off under Linux.

If I power on the system when the processor is cold, the BIOS will not switch on the fan, and the fan will be off when Linux boots. The fan will then never turn on, even when the processor warms up during usage.

If I then reboot the system (processor is warm), the BIOS will switch on the fan, and the fan will stay on when Linux boots. The fan then stays on, even when the processor reaches a cooler temperature.

So, it seems that the fan will not change state while Linux is booted. Is there any way to enable the fan to turn on and off automatically in Ubuntu?

I have tried both the 4.13 and 5.3 HWE kernels.

Thanks
 

Wen

KODLIX developer
Staff member
When the CPU temperature reaches 50 degrees, the fan will start to rotate,
Restart the system, the BIOS will initialize, and the fan will rotate for a short time. thanks
 

skip10

New Member
Thanks Wen - but the fan never comes on when booted into Ubuntu, even when CPU temp (as shown by "sensors") exceeds 50 deg.
 

Wen

KODLIX developer
Staff member
Can you provide me a picture of the CPU temperature exceeding 50 degrees? Maybe our method of detecting the temperature is different ,thanks.
 

Wen

KODLIX developer
Staff member
OKay ,thanks
Because the cpu fan noise is low, you can take out the unit and remove the motherboard for inspection.
I want to know more infomation , maybe you just want to solve the problem from the BIOS .
 

skip10

New Member
The fan works if I reboot when the CPU is hot - but then it will stay on even after the processor cools down. So I don't think it is a hardware problem.
 

skip10

New Member
I've resolved the problem by setting thermald to exclusive control mode:

Code:
$ sudo systemctl edit --full thermald.service

Update the line:
    ExecStart=/usr/sbin/thermald --no-daemon --dbus-enable

To:
    ExecStart=/usr/sbin/thermald --no-daemon --dbus-enable --exclusive-control
Now the fan starts whenever the system is under load.

Thanks
 
Top Bottom