< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

Doesn't boot

OscarReyes

New Member
Hi.
I have purchased 2 minisforum X5-Z8350 with w10. I used in my restaurant, attached at 2 touchscreen display only for browsing the restaurant POS
Three times, after power off, both X5-Z8350 doesn't boot.
After remove the battery for a while, is allrigth.
The batterys are ok. 3.1v
In this forum i saw it's a common thread
Why this happen?
How can i resolve it definitively?
I live in a country whit high ambient humidity so there are no static electricity.
Regards
Oscar
 

JayPeak

New Member
I am also having a problem powering up my Z83-F from MinisForum. It had been working fine, some dozens of power cycles. This morning I did a Win10 shutdown, then later tried to power up and the blue power light doesn't come on. I was planning to enter BIOS, and was trying F7 on the first try and it is possible it started to power up then and F7 somehow mad it hang up. I've tried reset button, power cycles, etc. When I plug a USB hub into the Z83F, the hub's blue indicator lights up indicating the Z83F is receiving power, but the Z83F blue light won't come on no matter what I try. Any help appreciated.
 

JayPeak

New Member
Aha.... Found this for another model https://bbs.minisforum.com/threads/j3455-not-booting-anymore.1306/ and the Solution #1 didn't work for me but #2 did. There were a few snags along the way and hopefully these tips will help anyone else with the same issue. Solved by power disconnected, then opening case and disconnecting yellow NVM battery for 2+ minutes. To open the case, peel off sticky rubber feet and remove screws underneath. Then use the screwed-on mounting bracket as a handle to wiggle the back from the case. Disconnect connector to battery. Let sit. When re-assembling, bracket goes on the same side as the 2x USB 2.0 connectors. Cheers, /george !
 
Top Bottom