< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

Clock speed stuck at 800Mhz or .79Ghz

selfhostedpro

New Member
I recently purchased a gd41 and my clock speed is stuck super low. It's lower performance wise than a Raspberry Pi4. I have tried disabling all of the power management settings, resetting the bios, the bios is the latest version. I've also tried the EC update for cpu performance but still have not had any luck.

Temperatures are around 60-65 degrees so it shouldn't be throttling.

This problem happens in both Windows and Linux. I believe it may be related to some bios settings. Can you provide the default bios options as well as give me some solutions to try?
 

joey

Administrator
Staff member
You can check your EC version to see if the update is successful. If the update is successful, the operating speed of the cpu will be significantly improved
 

moefear85

New Member
I had this problem too. The CPU has a feature called "Bidirectional Prochot", which allows various sensors on the Motherboard to tell the CPU to throttle down to the lowest possible speed. So Turboboost stops working, it stays at 800MHz (instead of 2.5GHz), and remains in various sleep C states most of the time (instead of C0 which is max performance).

The solution is to disable BD-Prochot in the BIOS. There is another option (I forgot its name), that decides who controls the processor's speed states. The possible values are "SW ANY", "SW ALL", and "HW ALL". Make sure it is "SW ANY" or "SW ALL". Then when you go into windows, make sure to set power settings to max performance, and set minimum cpu speed like max cpu speed to 100%. Also, after changing the BIOS, you have to power off the PC for the changes to take effect.

Either way, if you boot into linux, it ruins it and throttles it again, and it stays that way until you power off. There is a script with cryptic shell commands that you have to execute on every boot in linux in order to get it working there too. But even then, every time you want to switch back to windows, you have to power off first.

The source of the problem is crappy GD41 sensors/bios. Something is configured/wired incorrectly, or the bios has a bug, or it is done on purpose by the manufacturer. It means that the BD-Prochot option gets triggered automatically by some sensor without any justification, so that the processor never runs above minimum speed. It makes you think the cpu is too slow so you decide to go buy another system.
 
Top Bottom