< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

BIOS update for B550 did NOT fix the problem for 5000X CPU with 2 sticks of ram

toaruScar

Member
I have been struggling with a 5700X CPU and my B550 since I received it, as it always boot into Windows bluescreen with 2 stick of RAM.
After many exchanges with the CS, I received an updated BIOS that's compiled on July the 11th, which is supposed to fix the RAM problem, by reducing its frequency to 2666MHz.

However this did not fix my problem. The system would boot into desktop with 2 sticks of ram now, but would crash within 30 mins of use (gaming/video editing). A faster way to manifest this problem is to run prime95, and prime95's torture test would crash the system into BSOD within 10 seconds. I have checked in both the BIOS and Windows task manager that the RAM is running at 2666/2667MHz.

And with just 1 stick of RAM everything is fine even at 3200MHz.

Is there any development from the engineering team regarding this issue?
 
Last edited:

xhuz

New Member
I am also interested in an answer.
My b550 does not crash, and I have a 5700G cpu instead, but my ram also running at only 2667MHz although advertised to run at max. 3200 MHz, sounds like misleading advertising.
(and yes, my memory sticks support 3200MHz: Crucial Ballistic 2x 8GB, 3200MHz, 16cl, 1,35v,..)
 

toaruScar

Member
I am also interested in an answer.
My b550 does not crash, and I have a 5700G cpu instead, but my ram also running at only 2667MHz although advertised to run at max. 3200 MHz, sounds like misleading advertising.
(and yes, my memory sticks support 3200MHz: Crucial Ballistic 2x 8GB, 3200MHz, 16cl, 1,35v,..)
You can manually clock the RAM to run at 3200Mhz in BIOS.
 

toaruScar

Member
I can do that? Any guide how to?
Go to Advanced -> AMD CBS -> UMC common options ->DDR4 common options -> DRAM Timing Configuration -> Accept
Overclock: auto -> enable
Memory clock speed: auto ->1600MHz (because it is DDR (double data rate), you set it to be half of what you want).
 

xhuz

New Member
Go to Advanced -> AMD CBS -> UMC common options ->DDR4 common options -> DRAM Timing Configuration -> Accept
Overclock: auto -> enable
Memory clock speed: auto ->1600MHz (because it is DDR (double data rate), you set it to be half of what you want).
Thanks a lot, will try it out.
 
Top Bottom