< img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=177525256911397&ev=PageView&noscript=1" />

After reading all threads: Wifi still not available on Z83-F


New Member
Several weeks ago I bought the Z83-F Mini PC, installed latest Ubuntu version and saw that Wifi was not available. Tried to look at this forum but with no succes, thought a reinstall might do the job so I switched to Zorin OS 15.3 to try something new. Unfortunately Wifi is still not available with the same problems as the Ubuntu OS.

What I have tried so far:
- I followed this post and several others to put the brcmfmac43455-sdio.txt file in the correct place. I tried several versions of this file but with no succes.
- I tried to follow the BIOS setup (mentioned in the link above) to change the SCC SDIO Support option to PCI Mode instead of ACPI Mode, the chipset option (and advanced option) however is not available in my BIOS settings:


Using the lspci command, I can see that the ethernet controller is available, but on some startups this controller is also not available.

The text file shows output of the following commands: sudo dmidecode -t0, lspci, /lib/firmware/brcm$ ls and cat brcmfmac43455-sdio.txt

Without Wifi working this Mini PC is pretty useless for me so I really hope someone can help me out.

Is there a way to change BIOS versions? Should I try a different distro?

Thanks in advance!




Staff member
This wifi module currently does not support linux system, hope this information is helpful to you.


New Member
Thanks for your reply, but what do you mean with this wifi module? AP6255? or did you find the model name somewhere else? Also, do you know if an update for it is currently in the works?

But what about the ethernet controller, I could use that but sometimes the controller isn't available (have to restart then to get it back). Could you point me in a direction on how to fix this issue?


Staff member
If you are using a windows system, then refer to this document to modify the Ethernet configuration to fix it.



Do you have windows along side linux?

With the brcm file ap6255 should work. Try disabling wifi on windows and power on to linux. See if it can detect wifi.

Share output of this command.

dmesg | grep brcm
Top Bottom